lingvonotes.ru

Заметки о языках и не только :)

eDict. Справка

 

О программе

eDict (eDictionary) является простой программой для работы с электронными словарями. Поддерживает Unicode и соответственно может отображать и работать (при наличии шрифтов) с символами восточных и других неевропейских языков. Файлы словарей – это файлы БД, созданных в Microsoft Access, т.е. MDB.

Разделы справки:

 

Подготовка к работе

Если в Windows XP предполагается работа со словарями каких-либо восточных языков (арабский, китайcкий и т.п.), то для корректной работы и отображения текста нужно убедиться, что включена поддержка иероглифического письма и письма справа налево. Проверить это можно так:
открыть Пуск->Панель управления->Язык и региональные стандарты->вкладка «Языки».
Две «галочки» на этой вкладке должны быть установлены, также, как на рисунке ниже.

В более поздних версиях Windows (7, 8, 10 и др.) отображение восточных языков изначально включено.
Наверх

Транскрипция

Транскрипция в словарях дается, преимущественно, в формате МФА (Международный Фонетический Алфавит, он же IPA). Ссылка для справки: http://ru.wikipedia.org/wiki/Ipa
Наверх

Основное окно программы

  1. Меню программы
  2. Поле поиска
  3. Список слов
  4. Поля словарной статьи

Наверх

Меню программы
Меню «Dictionary» (Словарь)


Пункт «Open …» (Открыть)
С помощью этого пункта можно открыть новый словарь.

Пункт «Close» (Закрыть)
Этот пункт закрывает открытый ранее словарь.

Пункт «Direction» (Направление)

Позволяет выбрать направление поиска по словарю. Программа поддерживает дву- и трехнаправленые словари.

Пункт «Minimize to tray» (Свернуть в трей)

Сворачивает окно программы в трей. Также сворачивание срабатывает по клавише F12 или по нажатию на крестик в заголовке окна.

Пункт «Exit» (Выход)
Закрывает программу, без сворачивания в трей.

Меню «Edit» (Правка)

Пункт «Copy word» (Копировать слово)
Копирует в буфер обмена выбранное слово.

Пункт «Copy meaning» (Копировать значение)
Копирует в буфер обмена значение выбранного слова.

Меню «Search» (Поиск)

Пункт «Begin of word» (По началу слова)
Включает поиск в словаре по началу слова. В результате программа выдаст список слов, начинающихся с введенных символов.

Пункт «Part of word» (По части слова)
Включает поиск в словаре по части слова. В результате программа выдаст список слов, имеющих в своем составе введенные символы.

Меню «View» (Вид)

Пункт «Expert mode» (Режим эксперта)
При включении этого режима, программа позволяет редактировать словарные статьи. Подходит для исправления найденных ошибок и для составителей словарей.

Пункт «Language» (Язык)

Этот пункт переключает язык интерфейса. Переводы можно добавить с помощью DLL файлов, расположенных в папке lang.

Пункт «Wordlist» (Список слов)

Позволяет выбрать вариант отображения списка слов. По умолчанию включен оригинальный вид. При заполненном поле «Транслитерация» в словаре, появляется возможность отображать список слов в виде транслитерации.

Пункт «Minimizing to tray» (Сворачивать в трей)
Определяет действие кнопки закрытия программы в заголовке окна. Если включено, то при нажатии на нее программа сворачивается в трей. Если выключено – программа просто закрывается.

Меню «?» (Справка)


В этом меню можно вызвать этот файл помощи (также вызывается по нажатию кнопки F1 на клавиатуре), окно «About …» (О программе) или окно «About dictionary…» (О словаре). Если в словаре указана ссылка на его домашнюю страницу, то с помощью пункта «Visit the dictionary Homepage» (Перейти на сайт словаря) можно перейти на страницу словаря.
Наверх

Поле поиска


Вводя в это поле текст, автоматически производится поиск и фильтрация слов в зависимости от направления перевода, учета вхождений и режима отображения списка слов.
Наверх

Список слов


Выводит результат поиска по словарю. Сразу после открытия словаря, выводит все слова, входящие в него. Над списком отображается количество найденных слов. Имеет два режима: Оригинальные символы и Транслитерация. Режим переключается в меню «View» (Вид).
Наверх

Поля словарной статьи


В этих полях отображается вся информация о выбранном слове, имеющаяся в словаре. Если включен Режим эксперта, то они будут доступны для редактирования. Поля сверху вниз:

  • слово в оригинальном написании
  • транскрипция слова (может отсутствовать)
  • транслитерация слова, принятая для данного языка (может отсутствовать)
  • значение слова

Наверх